Fortnite - phase event not firing during some matches

Related Games: Fortnite
Related app/team name (not a must if you want to keep it private): FortniteAI
Issue Description: During certain matches the phase info event will not be triggered
Steps to reproduce: If you play a match and at the end of the match hit “ready up” without going back to the lobby and do this a few times you will usually get one match that does not have any phases triggered. At the end of the match if you were to then click “ready up” again the next match would usually have it. It happens randomly, sometimes it occurs the second match and other times it can be the tenth. For testing, we just keep landing and jumping off from a tall location to end the match quickly so we can test it. We tested quite a few times to and were looking at the direct events that were coming in from the listener to ensure that the events were not being triggered.
Impact for my app: show-stopper
Do you currently have a workaround? Nope.

Please reproduce and attach a zip package of your OW client logs
Will attach shortly.

Hi, and thanks for the feedback.

We will discuss the matter internally, and then we’ll update you.

Thanks.

@danv hi, we tried to reproduce this now, did about 10-15 sessions just killing myself each time and used the “ready up” button as mentioned by you.
Unfortunately, “phase” event worked fine each session, it never missed.

The only thing that I did find is that the inventory count event was sometimes skipping a sessions, which is a bug in and of itself, but it’s a separate subject.

Are you able to reproduce it and attach the logs?

I’ve sent you a DM in slack with the logs.

I forgot to mention that during our testing we have found this to happen in squads and duos. I haven’t yet tested extensively in solos to determine if it also happens there.

@danv thanks that’s important info.
I got the logs. We will check it and let you know.

Thanks.

@danv Re-creating this in squad/duo is far far far more time consuming and cannot be done quickly…

We tried our best with around 5 sessions straight and the phase events continued to work for us without any issue.

If this is consistently happening to you we can provide a gep_fortnite.dll to try and debug it.
Would you like to do that? it’s a special version of the dll that generate logs with much more details. That might help to “catch” more hints about what is causing the issue.

Sure, let’s do that as it needs to be fixed.

@danv, sure.

@Shargaas will attach here soon the plugin with the exact instructions.
Thanks.

Perfect, thanks. Will test again once I have it.

Hey @danv,
I’ve attached a plugin .dll which should help us debug this problem when it happens on your local computer.

Please follow these instructions:

  1. Take the dll file and copy it
  2. Open Overwolf settings
  3. Go to About tab
  4. Click “Development Options”
  5. Click the UID under “Game Events Provider”
  6. Go to Plugins/64
  7. Paste it there, override the existing file.

Now just play fortnite/do whatever you do in fortnite regularly.
If you stumble upon this problem again, please immediately go to the following location:

C:\Users(Your PC)\AppData\Local\Overwolf\Log - and send us the ‘gep_plugin’ file.

Thank you!

gep_fortnite.zip (306.6 KB)

1 Like

I just had the error happen again and managed to grab that file. I’ll send it through to @eransharv on slack.

Hey, have you had a chance to check?

Not yet, we’ve been preoccupied with a few urgent things in the past 2 days, i’ll try to get around to it today. Sorry for the delay.

Hi, any updates yet? It’d be good if we could at least get confirmation that you see the issue in the logs.

Hey,

Yeah we’ve already forwarded your logs to one of our devs, and it’s in his weekly tasks to look at it.
Hopefully we can get a fix out by the end of the week.