Issue with click events for Vuetify components and Vue Router

Issue Description:

When utilizing Vue’s Material Design UI library (called Vuetify) with the stock Vue Router we’re encountering an issue where the material <button> and material <select> components stop responding to event events after changing routes.

Steps to reproduce:

  • Load up the attached app file linked below.
  • You can switch between routes by selected HTML and Vuetify buttons in the toolbar at the top.
  • Jump back and forth between routes a few times
  • Try the HTML components. They click first time, no problem
  • Try the Vuetify components. Specifically button and select. They can take from 1-2 seconds to about 20 seconds before they respond to click events.

Note: you may have to try a few times as the click issue doesn’t always happen first try.

Impact for my app: show-stopper

App and Source files:

Basic App:
https://trello-attachments.s3.amazonaws.com/5cd5c72b8a7d021f09915fc1/5d237fd8a5113c095a09adfa/5bb395e60ea5f0412839c9fed6598983/test-app.zip

App Source:
https://trello-attachments.s3.amazonaws.com/5cd5c72b8a7d021f09915fc1/5d237fd8a5113c095a09adfa/ad0564683bf877c7c65aab31a1e4b8ee/test-app-source.zip

We’re using the following primary dependencies. See our package.json posted below for the full list:

  • Vue - our front end framework
  • Vue Router - for view routing (aka pages)
  • Vuetify - a Material Design UI library for Vue
  • Parcel - similar to Webpack, a build tool for packaging the code into bundles
{
  "dependencies": {
    "babel-polyfill": "^6.26.0",
    "vue": "^2.6.10",
    "vue-class-component": "^7.1.0",
    "vue-hot-reload-api": "^2.3.3",
    "vue-router": "^3.0.7",
    "vuetify": "^1.5.16"
  },
  "devDependencies": {
    "@vue/component-compiler-utils": "^3.0.0",
    "cssnano": "^4.1.10",
    "typescript": "^3.5.2",
    "vue-template-compiler": "^2.6.10"
  }
}

FYI, per console.log(navigator.appVersion) it appears Overwolf is running (a modified?) version 70.0.3538.77 of Chromium.

“Mozilla/5.0 (Windows NT 10.0; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/70.0.3538.77 Safari/537.36 OverwolfClient/0.131.0.15”

If this is correct this is approximately 9 months old:
https://www.filepuma.com/download/google_chrome_64bit_70.0.3538.77-20511/

Edit 1

Here’s the results of testing the app in both the current and same version of Chrome listed above:

  • Overwolf 0.131.0.15 :x:
  • Chrome 70.0.3538.77 :white_check_mark:
  • Chrome 75.0.3770.100 :white_check_mark:

Edit 2

Forgot to mention before. But when this issue occurs, clicks work without issue within the dev tools inspector preview window. So it appears not to be the app itself hanging or preventing use, but very strictly the ways it’s rendered in the main window itself.