[Minecraft] Add event support to All minecraft versions

As you probably know, Minecraft is one of the only games that has backward support & compatibility with older versions of the game.

Currently, Minecraft’s events are supported only in version 1.15 and above.

we would like to request support for events in all minecraft versions in order to support older clients too.

Order of Importance:

  • match_start & match_end: very important
  • server: nice to have

we don’t use the rest of the events so no other event is required :slight_smile:

Nonetheless, due to the vast amount of official Minecraft versions, I would also like to suggest to include a minimum supported Minecraft version field per event in the Minecraft documentation (https://overwolf.github.io/docs/api/overwolf-games-events-minecraft)

I need to check with the team what it means to support all versions, and if it’s possible and doable. I will let you know.

@itayG @ionatan.albu FYI.

Thanks.

1 Like

Either way, we’re planning to roll out with the existing support and continue from there :slight_smile:

@eransharv Any update from your end?

From our end, we’ve rolled out Minecraft support and wish to see more versions supported

HI @shir.brass. We can’t support ALL the old version. But we do want to support all the POPULAR versions. We are currently supporting the latest version, and shortly we will support version 1.12.2 as well. These the most popular versions, and we will check if there are more version that should get support.,

1 Like

We would like to cover as much as possible so sounds fair to me :slight_smile:
I do think though that we should know which version of minecraft is currently running & which versions are supported programmatically in order to let the users know whether we support their session or not

@eransharv Per one of our community members:

Can you guys try to make Outplay for Minecraft 1.8.9? That is the main version people play on when they pvp.

1 Like

We are currently working on adding a support for version 1.12.2 which is the most common version for “mod users”.

@Eyal please send us a prioritized version list (with users % if possible) and we’ll add it to our backlog

1 Like

@Eyal hi, any updates regarding the requested list?

I personally don’t have the data available. But I did a quick search in the web and this is what I have found:


(https://minecraft-statistic.net/en/global_statistic.html)

And another one:
image
(https://bstats.org/global/bukkit)

image
(https://support.hypixel.net/article/98-changing-minecraft-versions)

So to sum it up,
1.12.2 is a great addition
1.8.8/1.8.9 seems also to be a thing, not a priority for us.

If we can pull reliable data for editions and versions from Overwolf that would be much better.

Cheers

2 Likes

Thanks, @Eyal. We will take it from here.

@Eyal @shir.brass match_start & match_end & server IP (match_info) are supported in 1.12.2.

Currently no plans for 1.8.8/1.8.9.

Please tell me that everything is working as expected so I can move ahead and close this ticket.

1 Like

@eransharv We have tested it and everything seems to be working well for version 1.12.2. Thanks.

2 Likes