No audio when saving videos locally with overwolf.streaming

I’m trying to save a recording of an entire League of Legends game to a file and currently the video is saved, but there is no audio. I noticed the StreamAudioOptions Object also has “mic_volume” and “game_volume” fields, but there was still no audio when I included them. I tried using the “device_id” fields after calling “getAudioDevices” but that also didn’t work. And I also tried using NVIDIA_NVENC instead of X264, but there was still no audio.

code 
let streamSettings = {
  "provider": overwolf.streaming.enums.StreamingProvider.VideoRecorder,
  "settings": {
    "video": {
      "fps": 30,
      "sub_folder_name": "testvideos"
    },
    "audio": {
      "mic": {
        "volume": 100,
        "enabled": true
      },
      "game": {
        "volume": 75,
        "enabled": true
      }
    },
    "peripherals": { 
      "capture_mouse_cursor": overwolf.streaming.enums.StreamMouseCursor.gameOnly
    },
    "replay_type": overwolf.streaming.enums.ReplayType.Video
  }
};


// Start overwolf recording
overwolf.streaming.start(streamSettings, function(result) {

  if (result.status === "success") {
    console.log("START RECORDING");
    streamId = result.stream_id;
  }
  else {
    console.log("ERROR START RECORDING");
    console.log(result);
  }
});

@dannyao97 hi and welcome to the community!

We will investigate this issue and update you here.

Thanks,
Eran

@dannyao97 can you please reproduce the issue and send us your updated logs? you can attach here a zip package.

Hi @eransharv,
Here are the log files. I the videos were created on Oct. 08 around 3-5pm and Oct. 11 around 12pm. Thanks!
OverwolfLogs_2019-10-11_12-30-46.zip (857.1 KB)

Figured out the issue: The the setting is “enable” and NOT “enabled”. :man_facepalming: Thanks!