OW installer -> multiple issues

Issue Description:
please see attached images for the following issues:

  1. white background
  2. “installing” status for a while after complete the installation -> sent to Sergio
  3. no permissions for overlay - this is a new installation should be as default

Steps to reproduce:

  1. white background -> not sure, maybe random
  2. “installing” status for a while after complete the installation -> not sure, maybe random
  3. no permissions for overlay - this is a new installation should be as default -> install

Impact for my app:

  1. white background -> high
  2. “installing” status for a while after complete the installation -> low
  3. no permissions for overlay - this is a new installation should be as default -> very high -> need to give permissions and restart Overwolf after installation

OverwolfLogs_2020-11-09_12-32-58.zip (70.8 KB) KOipZIhxXz

Hey uzi,

Is this bug reproducible on your machine?

@itayG It happened to Itamar I’ll ask him and update

Hey @uzi,

I went over your original post and files, and I noticed a couple of things:

  1. The logs indicate that this system already had Overwolf installed, so it might have not been completely removed from the system when the re-installation was attempted (I can see the installer trying to delete some remaining log files).
  2. According to the logs, the installer is basic - it contains just the client and it’s not bundled with Facecheck. This might explain why the overlay for League didn’t get enabled by default (Facecheck only got installed later on).
  3. Regarding the installer banner being blank (white) - I couldn’t see the reason for this in the logs. Perhaps the QA team knows where exactly to look into this.
1 Like

@Heaser, are you familiar with this kind of issue?