Incorrect monitor handle returned by OW

Issue Description:
While R6 is running let’s say on monitor A, OW returns monitor B (until the game is minimized and maximized again and it fixes itself).
We use this feature to know on which monitor the app is running so we can create the 2nd monitor window on a different monitor than the game itself.

Related feature

Steps to reproduce:
high (because it makes our game window appear behind the game)

I am not sure if there are easier steps to repro this so i will tell you my setup.

  1. have a secondary monitor connected to a laptop and from the Project Menu (win + p) select second screen only.
  2. restart the laptop and wait. not the laptop should by default run on second monitor in windows with it’s own monitor turned off.
  3. Go back to the project menu (win +p) and select (extended)
  4. now the primary monitor should be the laptop one (if not set it to primary)
  5. To replicate this bug make sure windows identifies the external monitor as 1 and the internal one as 2 and 2 is primary.
  6. the game will by default for some reason run on monitor 1 and not on primary … thats just how r6 works i guess?) but the gameInfo will return the other monitor’s handle for some reason making us show our secondary monitor window behind the game and it’s affecting many users

My assumption: replicating the cumbersome steps above might not be necessary and selecting monitor 2 as primary might be enough (I do not know since i work on a laptop).

For us this is bug has a high impact because it completely ruins a feature for us, a window with a really really high completion rate adslot. We might look for ways around this for the time being but this bug really needs to get fixed otherwise the monitor handle feature itself is not really usable if it does not return proper information

Sadly until Christmas I will not be home and i do not have a secondary monitor so no useful logs but if it help i anyway i will ask someone to repro the steps for me.

@avner-solomon Thanks. We will check it and let you know ASAP.

@avner-solomon I have some issues to reproduce this bug:

Everything is ok until step 5 - The laptop defined as primary and attached to an external monitor in “extended” mode.

But on this configuration, windows always identifies the laptop as “1”. While in step 5, you mention “make sure windows identifies the external monitor as 1”.

BTW, from my tests, the game is always displaying on the primary screen, and the gameInfo identifies the monitors correctly.